Librarium Online Forums banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
anyone else having trouble sticking the guns/arms on the guys? i can never seem to match up the arms and guns with the body, do the guns/arms have to go to a specific body? anyone help me?

also i dunno if its something with new models or cadians, but my paint doesn't seem to stick to my cadians... it does to my other models but not cadian's, maybe its the paint, anyone else having this problem?
 

·
Registered
Joined
·
31 Posts
I can't remember, i believe their are individual guns for each arm set, numbered on the sprues, but I may be getting confused. Look at the gun sprues and if there are numbers there, then I remember right.
 

·
Registered
Joined
·
878 Posts
Ya, notice how each section of the sprue comes with a right and left arm. Use only the pair, don't mix and match. And if they still don't fit, a file kit and Epoxy Putty are your best friends.
P.S. Are you primng your Cadians? Because if you don't prime them, the paint will flake off.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #4 ·
well see i semi primed them oO... hehe, but the paint is coming off everywhere (now that i think of it, mostly on the parts where i didn't prime) but the thing is when i spray paint black, then add a couple layers of.... ummm, i think its called light brown (drawing a blank here) it gets to thick and less details :( do they have grey primer?
 

·
Registered
Joined
·
31 Posts
washing the sprues before painting helps almost as much as priming them, the more plastics i buy the more 'stuff' seems to be on them to stop paint sticking, aaargh
 

·
Registered
Joined
·
878 Posts
Yes, they do have Grey Primer.
Well, as to the other thing, are you sure you're using a thin enough coat, or maybe you're applying too much primer.
Is the paint you're thinking about Snakebite Leather? (Favorite Color)
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #7 ·
no its more of a tan color... but no i have them thin enough as i always do, and priming i do it enough so i still see alot of detail... so i dunno, maybe i just got a bad paint or something :(
 

·
Registered
Joined
·
1,659 Posts
First, as Raging Llama suggested, wash the sprues with warm soapy water and rinse.

Second, use actual primer to prime your miniatures. Black spray paint is not primer and doesn't stick any better than any other paint.

Sounds like you got a batch of miniatures with a good coating of mold release still on them. If your paint worked before, then it shouldn't just stop sticking. It probably isn't the paint. Also, wash your hands before painting. Skin oils can cause paint not to stick. Try not to handle the miniatures very much when your working with them. The paint may feel dry, but it isn't fully dry for about 24 hours and will rub off easily.
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top